Toolkit
About

Users

Developers

 

Access Grid Toolkit 2.4 - Mac OSX

Requirements:

  • OS X 10.3 or 10.4

Installation Instructions:

Release Notes:

  • Video Hardware:
    • Most Firewire cameras should be able to send video. Verified models include the iSight, iBot, and Panasonic DVX100a.
  • Audio Hardware:
    • You should either use the built-in audio device or a USB device that has been verified to work (listed below).
    • To use built-in audio, set it as the default audio device in "System Preferences", "Sound". Then, plug in a standard microphone* or if you have a laptop, you may select the built-in microphone. Be sure to prevent echo by using headphones or an echo-cancelling device.
    • Some USB microphones have been verified to work. Verified models include the Griffin iMic and the Plantronics DA50, DSP-100, and DSP-400.
    • The iSight microphone does not work well yet with the toolkit. It is recommended that you use it only for video, since using its microphone will cause your voice to sound lower and drop about 8% of the sound (due to differing sample rates).
      * If you have a G5 Power Mac (tower case):
      The line-in port does not work with standard computer microphones unless a preamplifier is used. Old Apple microphones and adapters (i.e. plainTalk) are also Not compatible with the G5 tower.
  • Encrypted venues are not yet supported and will crash rat, the audio program.
  • Some actions take a long time such as changing venues.
  • If you had previously installed the preview release and your VenueClient from the new release has difficulty starting up, removing the ".AccessGrid" folder in your home directory should help. It can be removed by doing a "File->Find" in the Finder, searching for invisible files, and moving it to the trash.
 

Installation on OS X 10.3 Panther:

  • Install wxPython
  • Install Tcl/Tk
  • Install X11
  • Install Access Grid Toolkit 2.4
  • Run AccessGridToolkit from your Applications folder

Software Download
Python 2.3
Included in OS X 10.3
wxPython 2.5.1.5**

Download

Tcl/Tk Aqua 8.4.9

Download

X11 for Mac OS X

Download

Access Grid Toolkit

Download


**It is not recommended you upgrade to wxPython 2.6 when using OS X Panther. That combinination currently makes elements in the VenueClient appear misaligned.


Installation on OS X 10.4 Tiger:

  • Install wxPython upgrade (Recommended, not required)
  • Install X11
  • Install Access Grid Toolkit 2.4
  • Run AccessGridToolkit from your Applications folder

Software
Download
Python 2.3
Included in OS X 10.4
wxPython

Included in OS X 10.4 (Version 2.5.3)

Recommended upgrade: ***
Download (Version 2.6.1.0)
Download (Additional Package required)

X11 for Mac OS X

Install from Tiger DVD Installation Disk

Insert the Tiger DVD.
Scroll the window down slightly.
Open the "Optional Installs" package.
When you see a list of package types, expand the "Applications" entry.
Check the "X11" box and continue.

Access Grid Toolkit 2.4

Download


*** Using OS X Tiger's default wxPython install (version 2.5.3) may cause the VenueClient to crash occasionally. To prevent this, it is recommended that Tiger users upgrade to a 2.6 version of wxPython.



 

 

For more information: ag-info@mcs.anl.gov